понедельник, 28 декабря 2020 г.

Опубликовать прайс 1C УТ на сайте #1 HTML

https://informatiktv.ru/index.php/1c/174-opublikovat-prajs-1c-ut-na-sajte-1-html
https://informatiktv.ru/index.php/1c/173-zapisat-fajl-po-ftp-cherez-1s

 &НаСервере

Функция ПодключитьсяКFTPСерверу()

Соединение = Новый FTPСоединение(

"ftp.io******232009.ioioi232.cp.regruhosting.ru", // адрес ftp сервера

21, // порт

"z753@avia3.ru", // логин

"Hromos44", // пароль


Неопределено, // прокси не используется

Истина, // пассивный режим работы

0, // таймаут (0 - без ограничений)

Неопределено // незащищенное соединение

);

Возврат Соединение;

КонецФункции


&НаСервере

Процедура ЗаписатьФайлНаСервере()


Соединение = ПодключитьсяКFTPСерверу();

Соединение.УстановитьТекущийКаталог("/public_html/");


ТекстовыйДок = Новый ТекстовыйДокумент;


Запрос = Новый Запрос;


Запрос.Текст =                                "ВЫБРАТЬ

| ЦеныНоменклатурыСрезПоследних.Номенклатура.Артикул КАК Артикул,

| ЦеныНоменклатурыСрезПоследних.Номенклатура КАК Номенклатура,

| ЦеныНоменклатурыСрезПоследних.Цена КАК Цена

|ИЗ

| РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних";


Запрос.УстановитьПараметр("ВидЦены", Справочники.ВидыЦен.НайтиПоНаименованию("Мин цена продажи"));

РезультатЗапроса = Запрос.Выполнить();

Выборка = РезультатЗапроса.Выбрать();


//Текст файла начало

ТекстовыйДок.ДобавитьСтроку("<h3 align = ""center"">Прайс</h3>");

ТекстовыйДок.ДобавитьСтроку("<table border = ""1"" align = ""center""><tbody>");

ТекстовыйДок.ДобавитьСтроку("<tr><td><b>Артикул111</b></td><td><b>Товар</b></td><td><b>Цена</b></td></tr>");


Пока Выборка.Следующий() Цикл

ТекстовыйДок.ДобавитьСтроку("<tr><td>" + Выборка.Артикул + "</td><td>" + Выборка.Номенклатура + "</td><td>" + Выборка.Цена + "</td></tr>");

КонецЦикла;


ТекстовыйДок.ДобавитьСтроку("</tbody></table>");

//Текст файла конец


ВременныйФайл = ПолучитьИмяВременногоФайла("html");

ТекстовыйДок.Записать(ВременныйФайл);

Соединение.Записать(ВременныйФайл,"testprice.html");

КонецПроцедуры


&НаКлиенте

Процедура ЗаписатьФайл(Команда)

ЗаписатьФайлНаСервере();

КонецПроцедуры


Комментариев нет:

Отправить комментарий